Messagenet e FreePBX: il numero che ha digitato non è in uso

Asterisk Support Forum. Discussioni generali.

Moderatori: rgbsyst3m, asterweb

Rispondi
eporedieis
Utente
Messaggi: 1
Iscritto il: domenica 3 febbraio 2019, 14:39

Messagenet e FreePBX: il numero che ha digitato non è in uso

Messaggio da eporedieis » domenica 10 febbraio 2019, 12:27

Buongiorno a tutti, sto provando da qualche settimana a configurare Asterisk tramite freePBX su Raspberry, ma senza successo. Ho un numero Messagenet e nonostante online si trovino un sacco di guide su come fare la configurazione, nessuna di queste sembra funzionare. In quasi tutti i casi una volta fatta la configurazione e chiamato il numero, risponde la segreteria di Messagenet. A forza di fare tentativi, togliendo da outbound "type=friend", chiamando parte la risposta "il numero che ha digitato non è in uso", che googlando mi pare di capire sia di Asterisk quindi forse è un mini passo avanti. Vi pubblico qua sotto la mia configurazione e il log, qualcuno potrebbe cortesemente aiutarmi a capire dove sto sbagliando? Sono settimane che ci sbatto la testa ma senza successo! Grazie mille!!

Controllando cosa succede in FreePBX nel momento delle chiamate, mi compaiono questi errori (googlando non ho trovato alcuna possibile soluzione, non so a cosa si riferiscano). Vi ho nascosto il numero di telefono mettendo "0*****".
[2019-02-03 11:54:50] WARNING[5561] pbx.c: Context 'from-trunk-sip-out_0*****' tries to include nonexistent context 'from-trunk-sip-out_0*****-custom'
[2019-02-03 11:54:50] WARNING[1104] chan_sip.c: Section 'in_0***** lacks type

p.s. il forum non mi lascia pubblicare link, quindi quando c'è l'url di messagenet ho sostituito il punto con un trattino, non si tratta di un errore reale :wink:

CONFIGURAZIONE

TRUNKS
General
Trunk name: 01***** (numero di telefono)
Hide CallerID: No
Outbound CallerID: il mio URI
CID: Force Trunk CID
Trunk dial options: System
Continue if busy: Yes
Disable trunk: No
Monitor trunk failures: No
Dialed Number Manipulations Rules
match pattern: [03]N.
Sip Settings - Outgoing
Trunk name: Messagenet
Peer details:
host=sip.messagenet-it
fromuser=il mio URI
secret=la mia pwd
transport=udp
defaultuser=il mio URI
fromdomain=sip.messagenet-it
port=5061
qualify=yes
insecure=invite,port
nat=force_rport
username=il mio URI
context=from-trunk
callbackextension=from-trunk
Sip settings - Incoming
User context: il mio URI
User details: [vuoto]
Register string: ilmioURI:lamiapwd@sip.messagenet-it:5061/

ASTERISK SIP SETTINGS
General SIP settings
Allow anonymous inbound sip calls: No (provando con Yes risponde di nuovo la segreteria di Messagenet)
Allow SIP Guests: Yes
Codecs: ilbc, gsm, alaw, ulaw
tutto il resto vuoto o con valori predefiniti
Chan SIP Settings
NAT: route (la connessione ce l'ho con Eolo, non ho ip fisso)
IP Configuration: Public IP
Enable TLS: No
Enable jitter buffer: Yes
Force jitter buffer: No
Implementation: Adaptive
Jitter Buffer Logging: No
Jitter Buffer Max Size: 200
Jitter Buffer Resync Threshold: 1000
Bind address: 0.0.0.0
Bind port: 5060
TLS Bind address: [::] (è segnato di default in grigetto)
TLS Bind port: 5161
Enable srv lookup: No
Enable TCP: Yes
Call events: No
Other SIP settings: directmedia=no | tcpenable=yes | tcpbindaddr=0.0.0.0

INBOUND ROUTES
Description: Nomedifantasia
DID Number: any
CallerID Number: any
CID priority route: no
Alert info: None
CID Name prefix:
Music on Hold: Default
Set destination: IVR > Aperto (mio IVR d'ingresso)

OUTBOUND ROUTES:
Route name: Telefono
Route CID: il mio URI
Override extension: Yes
Route password:
Trunk sequence for marched routes: 0*****

Eleggo a mio idolo personale chiunque riesca ad aiutarmi a risolvere il problema!! Grazieeee ancora!!

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Monta
Utente
Messaggi: 5
Iscritto il: lunedì 1 ottobre 2018, 21:37

Re: Messagenet e FreePBX: il numero che ha digitato non è in uso

Messaggio da Monta » domenica 5 maggio 2019, 19:01

Te la provo a buttare lì...prova a cambiare la stringa di registrazione in : Register string: ilmioURI:lamiapwd@sip.messagenet-it:5061/01***** (numero di telefono)

Poi prova di nuovo.

Fai anche un debug e guarda se ora passa il DID.
Eventualmente poi modifichi l'INBOUND ROUTES e provi ad intercettare il DID (ossia 01***** (numero di telefono))

Anche se la tua attuale INBOUND ROUTES dovrebbe essere un "cattura tutto".

Ciao
Ultima modifica di Monta il domenica 5 maggio 2019, 19:18, modificato 1 volta in totale.

Monta
Utente
Messaggi: 5
Iscritto il: lunedì 1 ottobre 2018, 21:37

Re: Messagenet e FreePBX: il numero che ha digitato non è in uso

Messaggio da Monta » domenica 5 maggio 2019, 19:04

Perdonami anche l'ultima osservazione: hai ricontrollato anche le impostazioni dell'account di Messagenet che non abbia ripristinato la segreteria come default.....non si sa mai.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Rispondi